0
0

FYI

I noticed a problem with YUM not running updates that are managed by Plesk when Cloudlinux is installed.

When I run Check for Updates in Plesk, it tells me YUM is locked and it also won’t install updates. For example, there’s been 9 Imunify360 updates available for weeks which appear in Plesk but they never update.

This error has appeared twice in Plesk: Warning: Information on some packages might not be actual: inconsistencies were detected in the system’s package manager database. Please resolve this issue manually.

I then try and run ‘yum update’ from CLI and get different errors.

1. [[email protected]┬átmp]# yum update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Existing lock /var/run/yum.pid: another copy is running as pid 1593649.
Another app is currently holding the yum lock; waiting for it to exit…

I had to use rm -f /var/run/yum.pid a few times before i could run yum update.

It then showed 104 updates which then finally appeared in plesk.

2. On another server, Yum generated Disk i/o error. I ran yum update again and it worked.

Something is not quite right with Yum when Cloudlinux is installed as it seems to take over yum updates and locks Plesk out or creates conflicts with Plesk over control of Yum which prevents regular system updates which Plesk should be managing.

This is fyi.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.

 

Use of this Site is subject to express terms of use. By using this site, you signify that you agree to be bound by these